Wired and Wireless Network Outage

Monitoring

Teams have implemented a fix and IT Services has confirmation that services have been restored.

Teams are continuing to monitor to ensure stability and validate root cause.
Posted Jun 30, 2026 - 21:43 EDT

Identified

Teams have narrowed on a cause and are actively investigating remediation methods. Further updates will be provided as available.
Posted Jun 30, 2026 - 21:18 EDT

Update

Teams have narrowed on a cause and are actively investigating remediation methods. Further updates will be provided as available.
Posted Jun 30, 2026 - 21:17 EDT

Update

Network disruption is impacting wired and wireless services, as well as PaperCut printing and Student Hub.
Posted Jun 30, 2026 - 21:07 EDT

Investigating

IT teams are investigating issues to the wired and wireless network across the Boston and Campuses. Updates will be shared to the IT Statuspage as they become available.

For any questions, or to report an issue, please contact the IT Service Desk at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jun 30, 2026 - 20:31 EDT
This incident affects: Network Infrastructure (NUnet (Wired Network / Physical), NUwave (Wireless Network / Access Points)).