Global Cloudflare Issues Impacting University Services

Resolved

Cloudfare has resolved this incident.
Posted Nov 18, 2025 - 13:59 EST

Update

Access to Claude.ai has been restored. Cloudflare reports that they are continuing to monitor to ensure all impacted services are fully restored.
Posted Nov 18, 2025 - 10:42 EST

Monitoring

Cloudflare is experiencing global service issues. This is impacting service for multiple sites and applications across the world, including some of which are used at Northeastern such as Claude.ai.

Cloudflare is working to address these issues and restore service. Updates from Cloudflare can be followed at https://www.cloudflarestatus.com/. University IT staff are monitoring.
Posted Nov 18, 2025 - 09:14 EST
This incident affected: Other.