This incident is resolved. Services across impacted campuses are fully restored, including Toronto. IT teams have confirmed network stability and will continue routine monitoring to ensure continued performance.
Thank you for your patience during this disruption.
IT teams are continuing to monitor the results. Local contacts have confirmed that most building access issues in Toronto are resolved, with a small number of buildings still impacted; teams are actively troubleshooting those remaining cases.
All other global campuses now have full building access restored.
Additional updates will be shared as more information becomes available.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal. ServiceNow
Posted Apr 17, 2026 - 10:33 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2026 - 20:43 EDT
Identified
A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2026 - 19:54 EDT
Update
Husky Card service is currently impacting building access. All other services are operating as normal
Posted Apr 16, 2026 - 18:53 EDT
Update
We are continuing to investigate this issue.
Posted Apr 16, 2026 - 18:23 EDT
Investigating
IT teams are investigating reports of Husky Card (CS Gold) access issues impacting multiple campuses, resulting in the Northeastern community being unable to use Husky Card–dependent services, including building access.This issue is affecting the CS Gold/Husky Card service across the global network.
Updates will be shared to the IT Statuspage as they become available.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.