Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 30, 2026 - 17:00 EDT
Scheduled
As a part of the 1Login initiative, maintenance to upgrade Gallagher (Student Healthcare) log in experience from 5 p.m. to 6 p.m. on Thursday, July 30. Community members may experience degraded services and an outage of up to 30 minutes during the maintenance window.
If an error message is encountered after the maintenance has been completed, clear your cache and attempt to log in again.
For more information about this initiative, visit the 1Login site.
If you require troubleshooting or IT support related to this change, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jul 28, 2026 - 16:26 EDT
This scheduled maintenance affected: Account Access and Security (Single Sign On (SSO)).