Login Errors l London Canvas

Update

Members of the London campus community are unable to log in to Canvas and Quercus. IT Services staff members have escalated to the vendor that supports these London services to resolve the issue.
Posted Jul 05, 2026 - 15:23 EDT

Investigating

IT teams are investigating reports of login errors affecting the London Canvas environment. Updates will be shared to the IT Statuspage as they become available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jul 05, 2026 - 13:40 EDT
This incident affects: Teaching and Learning (Canvas).