Articulate 360
Resolved
This incident has been resolved, access to Articulate 360 resources has been restored.
Posted Jan 12, 2022 - 12:53 EST
Investigating
Articulate 360 is investigating reports of users experiencing prolonged loading time and error messages when trying to access Rise 360 or view a Share links for Rise 360 courses. Additional information can be found by visiting articulatestatus.com.
Posted Jan 12, 2022 - 12:24 EST
This incident affected: Other.