Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 03, 2026 - 20:00 EDT
Scheduled
Maintenance to upgrade WebSphere services will take place from 5-7 p.m. PT / 8-10 p.m. ET on Thursday, June 4, and 1-3 a.m. GT on Friday, June 5.
Community members will experience a brief outage to the service applications listed below.
Impacted services: Cashnet Enterprise Photo Service Salesforce Forms Software Distribution LDAP Services uAchieve
All impacted services are expected to be fully restored by close of the maintenance window.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jun 03, 2026 - 15:40 EDT
This scheduled maintenance affected: Administration and Business (Banner - Finance, Banner - Self-Service) and Enterprise Systems, Other.