myNortheastern Portal Down
Resolved
The myNortheastern portal is back online.
Posted Apr 17, 2019 - 18:18 EDT
Identified
ITS is working with the vendor to resolve.
Posted Apr 17, 2019 - 17:46 EDT
Investigating
We are currently investigating this issue.
Posted Apr 17, 2019 - 16:19 EDT
This incident affected: Administration and Business (myNortheastern Portals).