Network issues l Dodge Hall - Boston

Resolved

IT teams have confirmed that the network is now fully operational in Dodge.
Posted Jan 27, 2026 - 10:13 EST

Investigating

Network monitoring shows potential issues affecting wireless access points in Dodge Hall. IT teams are investigating and assessing the impact and cause.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jan 27, 2026 - 08:19 EST
This incident affected: Network Infrastructure (NUwave (Wireless Network / Access Points)).