Student Hub Access Issues
Resolved
Students should no longer be experiencing this issue. If any issues persist, please contact the IT Service Desk at 617.373.HELP[4357] or help@northeastern.edu.
Posted Jan 14, 2021 - 09:29 EST
Update
Students should no longer be experiencing this issue. If any issues persist, please contact the IT Service Desk at 617.373.HELP[4357] or help@northeastern.edu.
Posted Jan 14, 2021 - 09:29 EST
Investigating
Some students are experiencing issues logging into the Student Hub and receiving a screen with "Oops, something's not right". The issue is being investigated.
Posted Oct 29, 2020 - 13:04 EDT
This incident affected: Student Services (Student Hub).