This issue has been fully resolved. Invoice processing and supplier profiles are working as expected.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted May 29, 2025 - 19:25 EDT
Identified
A partial fix has been applied and invoices for existing vendors in Banner should now be processing. Teams are continuing to work to fully resolve this issue for the rest of the vendors.
Posted May 29, 2025 - 15:58 EDT
Investigating
IT and Finance Teams are investigating issues with invoice processing and supplier profiles through the K2 form workflows. Account codes are showing as unavailable, restricting invoices from being submitted.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.