AWS Incident | Multiple Enterprise Services Impacted

Resolved

IT teams have confirmed that all university services that were impacted by yesterday's AWS incident are working normally.
Posted Oct 21, 2025 - 09:14 EDT

Monitoring

AWS has resolved their major incident. Canvas, Smartsheet, and Snowflake report that their services are now restored. Support chat on all university ServiceNow portals is fully restored. IT teams will continue to monitor services that were impacted by today's AWS outage.
Posted Oct 20, 2025 - 19:50 EDT

Update

ServiceNow chat features are affected by the AWS service disruption. Support chat on the Finance, Registrar, and Student Financial Services service portals are unavailable as a result. Chat on the Tech Service Portal is degraded but live agent chat is still available.

In the meantime, please use alternative ways to contact these university service centers if you require support.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Oct 20, 2025 - 12:07 EDT

Update

IT teams have received reports that the ServiceNow agent and chat features are not working as a result of the AWS outage.

Updates will continue to be shared to the IT Statuspage.
Posted Oct 20, 2025 - 11:32 EDT

Identified

A major outage to Amazon Web Services is impacting Northeastern community members using some enterprise services including Canvas, Smartsheet, and Snowflake. Community members may experience difficulty signing in, accessing data, or executing core services functions.

Impacts may extend beyond the listed services.

Track AWS impacts >
Track Canvas impacts >
Track Smartsheet impacts >
Track Snowflake impacts >

Updates on the status of impacts to Northeastern services will be shared to the IT Statuspage.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Oct 20, 2025 - 10:43 EDT
This incident affected: Teaching and Learning (Canvas, Other), Public Cloud Services (Amazon Web Services (AWS)), Enterprise Systems, Other, and Administration and Business (ServiceNow, ServiceNow Mobile App).