Inactivate Sponsored Accounts | Husky Card System

Resolved

IT teams have implemented a fix that has resolved the issue. Affected sponsored account members should now be reactive in the Husky Card system. If you're still experiencing issues, please contact the IT Service Desk.
Posted Feb 18, 2026 - 15:46 EST

Investigating

IT teams are investigating reports that, following the upgrade to version 9, some sponsored accounts are inactive in the Husky Card system.

If you experience this issue, please report it to the IT Service Desk for assistance.

Updates will be shared to IT Statuspage as available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Feb 18, 2026 - 13:21 EST
This incident affected: Account Access and Security (Sponsored Accounts).