A fix has been implemented, and access to account claim and password management has been restored. However, scheduled maintenance is currently in progress. Services are expected to be fully restored by close of the maintenance window at 8 a.m. ET on Monday, March 24. More information and updates can be found on the IT Statuspage.
Posted Mar 21, 2025 - 18:00 EDT
Identified
IT teams have identified the issue causing the password errors and are working as quickly as possible to restore services.
Posted Mar 21, 2025 - 17:56 EDT
Investigating
IT teams are investigating reports impacting Identity and Access Management. Password changes, password resets, and account claims are currently unavailable. Updates will be shared to the IT Statuspage.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], +44 20 3318 2507 for London, help@northeastern.edu, or visit the Tech Service Portal.
Posted Mar 21, 2025 - 14:16 EDT
This incident affected: Account Access and Security (Alumni Accounts, Faculty / Staff Accounts, Family / Other Accounts, Sponsored Accounts, Student Accounts), Student Services (Student Billing (Outsystems Link)), and Enterprise Systems.