Service Outage | MyMarketplace

Resolved

This issue has been resolved.
Posted Mar 25, 2025 - 15:59 EDT

Investigating

IT Services has received reports that community members are unable to access MyMarketplace. ITS teams are assisting with investigating the issue. Updates will be share to the IT Statuspage.

For any questions, or to report an issue, please contact the IT Service Desk at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Mar 25, 2025 - 11:18 EDT
This incident affected: Other.