IT teams have confirmed that the vendor resolved this issue. The university VPN is functioning normally.
Posted Jul 14, 2025 - 10:47 EDT
Monitoring
The university VPN is accessible and community members should be able to reconnect their devices. Please note that applications may need to be refreshed while some devices may require a reboot to reconnect to the university VPN.
Posted Jul 11, 2025 - 11:53 EDT
Identified
ITS teams have confirmed that the VPN issue is being caused by a problem with Verizon FIOS. The ITS team has adjusted the configuration of the VPN to bypass this issue until Verizon implements a permanent fix.
Posted Jul 11, 2025 - 11:29 EDT
Investigating
IT teams are investigating reports from community members who are unable to connect the Northeastern University Palo Alto Global Protect VPN at this time. Updates will be shared to the IT Statuspage.
For any questions, or to report an issue, please contact the IT Service Desk at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jul 11, 2025 - 11:14 EDT
This incident affected: Network Infrastructure (VPN).